Author Topic: json_rpc_call failed, retry after 30 seconds?  (Read 2732 times)

andylittleton

  • Newbie
  • *
  • Posts: 5
    • View Profile
json_rpc_call failed, retry after 30 seconds?
« on: April 17, 2017, 06:02:09 pm »
Hi.  I went to my spreadcoin wallet,  played with the settings by going to network and tried the connect through SOCKS proxy:

I applied that setting and restarted my wallet,  Tried mining but that didn't work,   So i went back to the network settings and unchecked connect through socks proxy to get it all back to default settings.

Tried mining again and keep getting json_rpc_call_failed,   before i used to connect and mine but wasn't getting any coins, only did it for 30 minutes.

Anyway how do get back on the right path to mine with my nvidia 970 gtx.

I just double clicked the example file for nvidia spreadcoin miner.  is that correct or do i got to change something in the example file?
spreadminer -o http://127.0.0.1:41677 -u rpcuser -p rpcpass

Thanks a lot

andylittleton

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: json_rpc_call failed, retry after 30 seconds?
« Reply #1 on: April 17, 2017, 06:50:09 pm »
to add further information.

it also says http request failed: the requested URL returned error:500 internal server error. 

this happens when i run the spreadminer_v0.1r3 example batch file

jjjordan

  • Newbie
  • *
  • Posts: 48
    • View Profile
Re: json_rpc_call failed, retry after 30 seconds?
« Reply #2 on: April 18, 2017, 07:16:21 am »
I assume you have both the wallet and spreadminer on the same computer.
Make sure  -u rpcuser -p rpcpass from your spreadminer startup line match the ones in your spreadcoin.conf.
It's located at %APPDATA%\Spreadcoin or wherever you have your wallet data.
It should contain something like that:

Code: [Select]
rpcuser=rpcuser
rpcpassword=rpcpass
rpcallowip=127.0.0.1
rpcallowip=192.168.1.*
rpcport=41677
port=41678
gen=0
server=1

When you start the wallet make sure you start mining (with wallet even with 0 cores).
Then you should be able to connect.

andylittleton

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: json_rpc_call failed, retry after 30 seconds?
« Reply #3 on: April 20, 2017, 04:41:08 am »
Hi.  So the fix to get it working back to normal again was just simply deleting my wallet and stuff in roaming folder and reinstalling it,  Kept the block files so it doesn't have to spend half a day to sync it all.

all seems to be working good now with the nvidia spreadcoin miner however I wanted to confirm if just simply double clicking the example file is fine and nothing to change from the default settings?  Here's the file in it's exact text.  Do i need to change the user or password or just leave it alone is fine?  I just want to make sure I don't spend two days mining for nothing if it's donating it

spreadminer -o http://127.0.0.1:41677 -u rpcuser -p rpcpass

thanks for the help
Modify message